Saturday, December 30, 2006

Installing "Edgy" HOWTO

Ubuntu is a fine and easy to install Linux distro but of course it doesn't lack some small bugs or other little issues, but they are easy to overcome - if you know how... I thought I'd sum it all up in one little install HOWTO. (Please keep in mind: this is the way I got it working for my amd64 system...) Here we go!

Friday, December 29, 2006

Ubuntu it is - again

So, I went for Ubuntu Edgy. Fedora Core 6 gave me some hard times updating because yum couldn't resolve some dependencies - I never had this kind of trouble with Debian's apt.

My former experience with Kubuntu Edgy taught me to download the "alternate" install-CD right away. The installation is pretty much the same as with the "desktop" install-CD, but you have the choice to install "grub" not only to the MBR. As I mentioned, my motherboard (and I found some clues that there are a lot of boards with nForce5/AM2 chip set with similar problems) has some issues with Linux. To be precise, without additional kernel options almost no distro would boot. There are two options which made the kernel boot correctly:
  • acpi=off

  • noapic (preferred!)
With "acpi=off" Linux boots but you have no ACPI support what so ever. This means no "powernow" (CPU frequency scaling) and no automatic power-off after shutdown. If applicable I'd go for the second option "noapic". I don't no exactly what it does, but I think it has something to do with PCI interrupts. This option works pretty well and you still have ACPI support.
To boot the Ubuntu install-CD you have to press "F6" at the boot screen and add "noapic" (without the quotation marks) at the end of the line right before the "--" and then hit "Enter". That's it - for now... The bad news is that the installer doesn't remember that extra option and won't add it to the Grub-boot loader configuration file automatically. I'm going to write a short HOWTO about installing Ubuntu on a system like mine where I'll explain how to overcome this issue.

By the way, Ubuntu doesn't have the problem (like Kubuntu) that all drives mounted under /media disappear after logout/login - either they fixed it or it never appeared in Ubuntu.

Tuesday, December 26, 2006

Back again!

I'm back - finally! I got a new computer (no, not for Christmas, bought the parts myself a few weeks ago and assembled it myself) and until now it works great. Hopefully it stays that way...

The main specs are:
  • Gigabyte GA-M55S-S3 (nForce5) motherboard
  • AMD Athlon 64 X2 4200 (Dual Core) CPU
  • Gainward BLISS 7600GT 256MB video card
  • 2 GB RAM (dual channel enabled)
Though there are some quirks concerning Linux and ACPI support with the current BIOS of the motherboard I'm pretty content with everything - as there is a workaround this issue. I will write something about that in the near future, but I'm still undecided which Linux distro I should use... At the moment it's boiling down to Ubuntu 6.10 or Fedora Core 6. Well, let's see and be sure that I'll let you know ;-)